We're updating the issue view to help you get more done. 

Upgraded master cannot replicate DB to freshly installed slave

Description

Given a master installed in Wazo < 19.12, upgraded to 20.02
Given a slave installed freshly in 20.02
When I run xivo-master-slave-db-replication <slave>
Then I see an error

Expected: Replication finished successfully.

Workaround:

On the master, run:

Then restart the DB replication.

Technical details: The master has to be installed in Debian Stretch (Wazo <= 19.12) and the slave has to be installed in Debian Buster ( Wazo >= 19.13).

  • stretch use sqlalchemy: 1.0.15

  • buster use sqlalchemy: 1.2.18

Changed behavior in 1.1: https://docs.sqlalchemy.org/en/13/changelog/migration_11.html#change-3216

Environment

None

Activity

Show:
Mathias Wolff
March 16, 2020, 1:45 PM

if the task does not take too much time (max 2h), you can resolve the bug, else we won't do !

Assignee

François Blackburn

Reporter

Sébastien Duthil

Approvers

Pascal Cadotte

Pair

None

Sprint

None

Fix versions

Priority

Medium
Configure